Not logged in. · Lost password · Register
Forum: agsXMPP RSS
Can't login to openfire server using my app, but other xmpp clients can connect using the same username and password
Page: previous  1  2 
Avatar
yopy_yogie #16
Member since Jun 2010 · 8 posts
Group memberships: Members
Show profile · Link to this post
In reply to post ID 5002
Thank's for the reply
But doesn't user name must supply a domain name?

Regards
Avatar
Alex #17
Member since Feb 2003 · 4297 posts · Location: Germany
Group memberships: Administrators, Members
Show profile · Link to this post
no,

a Jid in XMPP has the following format.

user@server.org/resource

user = username, also called node
server.org = xmpp domain
resource = xmpp reesource

Alex
Avatar
yopy_yogie #18
Member since Jun 2010 · 8 posts
Group memberships: Members
Show profile · Link to this post
In reply to post ID 5002
Quote by Alex:
your username is wrong because it includes the domain. The correct username is jabberd1 in your case.

Alex

Still show the same error message ....
Avatar
yopy_yogie #19
Member since Jun 2010 · 8 posts
Group memberships: Members
Show profile · Link to this post
Dear Alex,
Sorry, I've made a mistake in the code.
Your suggestion is worked.

Thank You.
Avatar
yopy_yogie #20
Member since Jun 2010 · 8 posts
Group memberships: Members
Show profile · Link to this post
Dear Alex,
I really can not understand. Last night i have try your suggestion and it did worked.
But right now i try to connect again, and the same error message shows.

I am using OpenFire server on the local network which name is spc-ubuntu.
username = jabberd1
ConnectServer = spc-ubuntu (can i change this to IP?)

The security setting on the Server is set to "Required"

Here is the code from MiniClient (use port 5222) :

//_connection.Server                      = jid.Server;
_connection.Username                    = txtJid.Text;
_connection.Password                    = txtPassword.Text;
_connection.Resource = null;// txtResource.Text;
_connection.Priority                    = (int) numPriority.Value;
_connection.Port                        = int.Parse(txtPort.Text);
//_connection.UseSSL                        = chkSSL.Checked;
_connection.ConnectServer = txtServer.Text; // Openfire server (spc-ubuntu)
_connection.AutoResolveConnectServer    = false;               
_connection.UseStartTLS    = true;

Here is debug log:

SEND: <stream:stream to='jabberd1' xmlns='jabber:client' xmlns:stream='http://etherx.jabber.org/streams' version='1.0' xml:lang='en'>
RECV: <stream:stream xmlns:stream="http://etherx.jabber.org/streams" from="spc-ubuntu" version="1.0" xml:lang="en" id="588e63eb" >
RECV: <stream:features xmlns:stream="http://etherx.jabber.org/streams"><starttls xmlns="urn:ietf:params:xml:ns:xmpp-tls"><required /></starttls><mechanisms xmlns="urn:ietf:params:xml:ns:xmpp-sasl"><mechanism>DIGEST-MD5</mechanism><mechanism>PLAIN</mechanism><mechanism>CRAM-MD5</mechanism></mechanisms></stream:features>
SEND: <starttls xmlns="urn:ietf:params:xml:ns:xmpp-tls" />
RECV: <proceed xmlns="urn:ietf:params:xml:ns:xmpp-tls" />
SEND: <stream:stream to='jabberd1' xmlns='jabber:client' xmlns:stream='http://etherx.jabber.org/streams' version='1.0' xml:lang='en'>
RECV: <stream:stream xmlns:stream="http://etherx.jabber.org/streams" from="spc-ubuntu" version="1.0" xml:lang="en" id="588e63eb" >
RECV: <stream:features xmlns:stream="http://etherx.jabber.org/streams"><mechanisms xmlns="urn:ietf:params:xml:ns:xmpp-sasl"><mechanism>DIGEST-MD5</mechanism><mechanism>PLAIN</mechanism><mechanism>CRAM-MD5</mechanism></mechanisms><compression xmlns="http://jabber.org/features/compress"><method>zlib</method></compression><auth xmlns="http://jabber.org/features/iq-auth" /></stream:features>
SEND: <auth xmlns="urn:ietf:params:xml:ns:xmpp-sasl" mechanism="DIGEST-MD5" />
RECV: <challenge xmlns="urn:ietf:params:xml:ns:xmpp-sasl">cmVhbG09InNwYy11YnVudHUiLG5vbmNlPSJ3QWlTajBkVURRR1B0RWRWU2pXajJqSitiUnd3R1VRY2hTZjliVkFjIixxb3A9ImF1dGgiLGNoYXJzZXQ9dXRmLTgsYWxnb3JpdGhtPW1kNS1zZXNz</challenge>
SEND: <response xmlns="urn:ietf:params:xml:ns:xmpp-sasl">dXNlcm5hbWU9ImphYmJlcmQxIixyZWFsbT0ic3BjLXVidW50dSIsbm9uY2U9IndBaVNqMGRVRFFHUHRFZFZTaldqMmpKK2JSd3dHVVFjaFNmOWJWQWMiLGNub25jZT0iMDljNjk5ZjNmMDU4ZjkyZTgwMmNhYzI5MTVmNjdlMzBhZTVlMzk5ZTMxY2JmZGIzMDdlMjYwNmM5NGI3YTgxNCIsbmM9MDAwMDAwMDEscW9wPWF1dGgsZGlnZXN0LXVyaT0ieG1wcC9qYWJiZXJkMSIsY2hhcnNldD11dGYtOCxyZXNwb25zZT02ZGUyODI2ZDY1M2RhZGRjNmQ1YjA3ZjZiMDE2NzhlOA==</response>
RECV: <failure xmlns="urn:ietf:params:xml:ns:xmpp-sasl"><not-authorized /></failure>
SEND: </stream:stream>
RECV: </stream:stream>

What is wrong with me?
Please help.

Best Regards.
Avatar
Alex #21
Member since Feb 2003 · 4297 posts · Location: Germany
Group memberships: Administrators, Members
Show profile · Link to this post
Quote by yopy_yogie:
SEND: <stream:stream to='jabberd1' xmlns='jabber:client' xmlns:stream='http://etherx.jabber.org/streams' version='1.0' xml:lang='en'>

to is in your log jabberd1 which is wrong, because you said the server is configured to the domain spc-ubuntu.
This means you have set the Server property wrong.

Alex
Avatar
yopy_yogie #22
Member since Jun 2010 · 8 posts
Group memberships: Members
Show profile · Link to this post
Quote by Alex:
Quote by yopy_yogie:
SEND: <stream:stream to='jabberd1' xmlns='jabber:client' xmlns:stream='http://etherx.jabber.org/streams' version='1.0' xml:lang='en'>

to is in your log jabberd1 which is wrong, because you said the server is configured to the domain spc-ubuntu.
This means you have set the Server property wrong.

Alex

So how do i fix this error? can you give any suggestion?
The domain setting in the openfire refers to spc-ubuntu.
Avatar
yopy_yogie #23
Member since Jun 2010 · 8 posts
Group memberships: Members
Show profile · Link to this post
Finally, i can connect to server.
But the presence of other user which online can not be updated. It still show offline.
Any idea?

Regards
Avatar
Alex #24
Member since Feb 2003 · 4297 posts · Location: Germany
Group memberships: Administrators, Members
Show profile · Link to this post
you get the presence in the OnPresence event. If you don't get presence then users are either not in your contact list or you have no subscription.

Alex
Close Smaller – Larger + Reply to this post:
Verification code: VeriCode Please enter the word from the image into the text field below. (Type the letters only, lower case is okay.)
Smileys: :-) ;-) :-D :-p :blush: :cool: :rolleyes: :huh: :-/ <_< :-( :'( :#: :scared: 8-( :nuts: :-O
Special characters:
Page: previous  1  2 
Forum: agsXMPP RSS