Not logged in. · Lost password · Register
Forum: MatriX RSS
Avatar
Arthur #1
Member since Feb 2010 · 13 posts
Group memberships: Members
Show profile · Link to this post
Subject: Need help authorizing with Soapbox server
Hi, I'm trying to connect to a SoapBox server.  I have no problems connecting to an OpenFire server.
I'm using the MiniClient example.

Any help/tips?

I get an AuthorizeError.  Here is the xml

SEND: <stream:stream xmlns:stream="http://etherx.jabber.org/streams" xmlns="jabber:client" to="platform.com" version="1.0" >
RECV: <stream:stream xmlns:stream="http://etherx.jabber.org/streams" from="platform.com" xml:lang="en-us" id="b0673588-0c36-4b9a-a16c-b8fc9ffaa686" xmlns="jabber:client" version="1.0" >
RECV: <stream:features xmlns:stream="http://etherx.jabber.org/streams">
  <register xmlns="http://jabber.org/features/iq-register" />
  <auth xmlns="http://jabber.org/features/iq-auth" />
  <mechanisms xmlns="urn:ietf:params:xml:ns:xmpp-sasl">
    <mechanism>PLAIN</mechanism>
    <mechanism>DIGEST-MD5</mechanism>
  </mechanisms>
</stream:features>
SEND: <auth mechanism="DIGEST-MD5" xmlns="urn:ietf:params:xml:ns:xmpp-sasl" />
RECV: <challenge xmlns="urn:ietf:params:xml:ns:xmpp-sasl">cmVhbG09InBsYXRmb3JtLm1pdGNoZWxsLmNvbSIsbm9uY2U9IjBmYTg2M2M5YzYwNzRkZGE5ZjJhYjdlYWFiMzJlMmIwIixxb3A9ImF1dGgiLGNoYXJzZXQ9dXRmLTgsYWxnb3JpdGhtPW1kNS1zZXNz</challenge>
SEND: <response xmlns="urn:ietf:params:xml:ns:xmpp-sasl">dXNlcm5hbWU9IkFydGh1ckBwbGF0Zm9ybS5taXRjaGVsbC5jb20iLHJlYWxtPSJwbGF0Zm9ybS5taXRjaGVsbC5jb20iLG5vbmNlPSIwZmE4NjNjOWM2MDc0ZGRhOWYyYWI3ZWFhYjMyZTJiMCIsY25vbmNlPSI2NjYzNDhkODMyNTRhYTQzYjQ3Y2MwOGZjZjQ4YTNkMDM0YmZmNTcwNzE4NWEyZDUyNzVmMzU0NzVmMDkxMTVmIixuYz0wMDAwMDAwMSxxb3A9YXV0aCxkaWdlc3QtdXJpPSJ4bXBwL3BsYXRmb3JtLm1pdGNoZWxsLmNvbSIsY2hhcnNldD11dGYtOCxyZXNwb25zZT05MzUzMGUyZDkwMzZkNzU2YWM4NDgwYzY5NGFjY2YwYw==</response>
RECV: <failure xmlns="urn:ietf:params:xml:ns:xmpp-sasl">
  <not-authorized />
</failure>
SEND: </stream:stream>
Avatar
Arthur #2
Member since Feb 2010 · 13 posts
Group memberships: Members
Show profile · Link to this post
Nevermind, I was able to figure it out.

I was setting xmppClient.Username = "arthur@platform.com"
This will work with OpenFire but not SoapBox.

With SoapBox you need to remove the domain - xmppClient.Username = "arthur"
Avatar
Alex #3
Member since Feb 2003 · 4297 posts · Location: Germany
Group memberships: Administrators, Members
Show profile · Link to this post
Quote by Arthur:
With SoapBox you need to remove the domain - xmppClient.Username = "arthur"

A Jid has the format user@domain/resource. The username is everything before the "@". Its mere chance that it was working on Openfire.

Alex
Close Smaller – Larger + Reply to this post:
Verification code: VeriCode Please enter the word from the image into the text field below. (Type the letters only, lower case is okay.)
Smileys: :-) ;-) :-D :-p :blush: :cool: :rolleyes: :huh: :-/ <_< :-( :'( :#: :scared: 8-( :nuts: :-O
Special characters:
Forum: MatriX RSS