Not logged in. · Lost password · Register
Forum: agsXMPP RSS
Avatar
bearstand #1
Member since Feb 2009 · 5 posts · Location: China
Group memberships: Members
Show profile · Link to this post
Subject: Openfire connection problems
Hi
I am Using agsXMPP2008 sample(Miniclient) to connect my Openfire server,but it shows that wrong usename or wrong password.
when I use the Spark to connect the Openfire with Same Username and Password,it works fine. So,I changed the Client to xeus and NHIM.unfortunately,they doesn't anth the password too. Maybe I do something wrong,Plz correct me!

BTW:
my debug messages:
SEND: <stream:stream to='ecall.com.hk' xmlns='jabber:client' xmlns:stream='http://etherx.jabber.org/streams' version='1.0' xml:lang='en'>
RECV: <stream:stream xmlns:stream="http://etherx.jabber.org/streams" from="127.0.0.1" version="1.0" xml:lang="en" id="8eb7c70b" >
RECV: <stream:features xmlns:stream="http://etherx.jabber.org/streams"><starttls xmlns="urn:ietf:params:xml:ns:xmpp-tls" /><mechanisms xmlns="urn:ietf:params:xml:ns:xmpp-sasl"><mechanism>PLAIN</mechanism><mechanism>CRAM-MD5</mechanism><mechanism>DIGEST-MD5</mechanism></mechanisms><compression xmlns="http://jabber.org/features/compress"><method>zlib</method></compression><auth xmlns="http://jabber.org/features/iq-auth" /><register xmlns="http://jabber.org/features/iq-register" /></stream:features>
SEND: <starttls xmlns="urn:ietf:params:xml:ns:xmpp-tls" />
RECV: <proceed xmlns="urn:ietf:params:xml:ns:xmpp-tls" />
SEND: <stream:stream to='ecall.com.hk' xmlns='jabber:client' xmlns:stream='http://etherx.jabber.org/streams' version='1.0' xml:lang='en'>
RECV: <stream:stream xmlns:stream="http://etherx.jabber.org/streams" from="127.0.0.1" version="1.0" xml:lang="en" id="8eb7c70b" >
RECV: <stream:features xmlns:stream="http://etherx.jabber.org/streams"><mechanisms xmlns="urn:ietf:params:xml:ns:xmpp-sasl"><mechanism>PLAIN</mechanism><mechanism>CRAM-MD5</mechanism><mechanism>DIGEST-MD5</mechanism></mechanisms><compression xmlns="http://jabber.org/features/compress"><method>zlib</method></compression><auth xmlns="http://jabber.org/features/iq-auth" /><register xmlns="http://jabber.org/features/iq-register" /></stream:features>
SEND: <auth xmlns="urn:ietf:params:xml:ns:xmpp-sasl" mechanism="DIGEST-MD5" />
RECV: <challenge xmlns="urn:ietf:params:xml:ns:xmpp-sasl">cmVhbG09IjEyNy4wLjAuMSIsbm9uY2U9IlhkVGgrTWo0azhoaGdMZ2Z4WVp4RVQ5KzFFdTJScFlpR05ESllySnEiLHFvcD0iYXV0aCIsY2hhcnNldD0idXRmLTgiLGFsZ29yaXRobT0ibWQ1LXNlc3Mi</challenge>
SEND: <response xmlns="urn:ietf:params:xml:ns:xmpp-sasl">dXNlcm5hbWU9IjEzNzU1MTAwODY1IixyZWFsbT0iMTI3LjAuMC4xIixub25jZT0iWGRUaCtNajRrOGhoZ0xnZnhZWnhFVDkrMUV1MlJwWWlHTkRKWXJKcSIsY25vbmNlPSIyYThiNGVmZGNjZDBjZmU4ZTBmYzdhMWQ1ZTFkYTAzZWI5MjU2YWM2NzIxZjU1YmYyYzgwNjE1Y2U1YzhiYTA2IixuYz0wMDAwMDAwMSxxb3A9YXV0aCxkaWdlc3QtdXJpPSJ4bXBwL2VjYWxsLmNvbS5oayIsY2hhcnNldD11dGYtOCxyZXNwb25zZT03NGFkOGU1NmQ0ZDAxMjcwMGViODlkZGFkZGI3MzQ1Zg==</response>
RECV: <failure xmlns="urn:ietf:params:xml:ns:xmpp-sasl"><not-authorized /></failure>
SEND: </stream:stream>
RECV: </stream:stream>

Plz help me~Thx~
This post was edited on 2009-02-02, 08:23 by bearstand.
Avatar
Jabberer #2
Member since Feb 2006 · 249 posts
Group memberships: Members
Show profile · Link to this post
your server is configured to localhost, which is wrong, because you send the stream to ecall.com.hk.

SEND: <stream:stream to='ecall.com.hk' xmlns='jabber:client' xmlns:stream='http://etherx.jabber.org/streams' version='1.0' xml:lang='en'>
RECV: <stream:stream xmlns:stream="http://etherx.jabber.org/streams" from="127.0.0.1" version="1.0" xml:lang="en" id="8eb7c70b" >
Software Developer
AG-Software
Avatar
bearstand #3
Member since Feb 2009 · 5 posts · Location: China
Group memberships: Members
Show profile · Link to this post
Thx for your reply.
I will try to change my server's configure.But,I didn't clear why the Spark can connect to my server with username and password correctely.
Avatar
bearstand #4
Member since Feb 2009 · 5 posts · Location: China
Group memberships: Members
Show profile · Link to this post
All of them work fine. Thx a lot~~:)
Avatar
Alex #5
Member since Feb 2003 · 4297 posts · Location: Germany
Group memberships: Administrators, Members
Show profile · Link to this post
In reply to post #3
Quote by bearstand:
But,I didn't clear why the Spark can connect to my server with username and password correctely.

agsXMPP is using by default the most secure authentication mechanism supported by the server. Which is SASL DIGEST-MD5 in your case. This mechanism includes the domain, and authentication will only work when the domain matches.

The SASL PLAIN mechanism does not include the domain and sends username and password in plain text. Because it does not include the domain authentication will success even with broken server configurations. So I assume Spark is using SASL PLAIN because it works.
This post was edited on 2009-02-04, 11:08 by Alex.
Avatar
bearstand #6
Member since Feb 2009 · 5 posts · Location: China
Group memberships: Members
Show profile · Link to this post
Thank you for Jabberer and Alex.
Now ,the MiniClient works fine.I can use it send messages to other client (e.g Spark,Glu).
This post was edited on 2009-02-04, 08:31 by bearstand.
Avatar
josinvill #7
Member since Aug 2009 · 1 post
Group memberships: Members
Show profile · Link to this post
Thanks :)
Avatar
cvg #8
Member since Aug 2009 · 1 post
Group memberships: Members
Show profile · Link to this post
In reply to post #6
Hi alex my server is open fire and server setting is not localhost but i cant login "Authentication Error Wrong password".

 Please testing my account where is my mistake (using miniclient)


              Jid my = new Jid(txtJid.Text); // hht@esx10-2022
              my.Server = label2.Text; //ns3.anasel.com
              my.User = "hht";

              _connection.Username = txtJid.Text; //hht
              _connection.Server = label2.Text; //ns3.anasel.com
              _connection.Password = txtPassword.Text; //1
              _connection.Resource = txtResource.Text; 

              _connection.Priority = (int)numPriority.Value;
              _connection.Port = int.Parse(txtPort.Text);
              _connection.UseSSL = chkSSL.Checked;
              _connection.AutoResolveConnectServer = true;
              _connection.UseCompression = false;
 
              if (chkRegister.Checked)
                  _connection.RegisterAccount = true;
              else
                  _connection.RegisterAccount = false;

              // Caps
              _connection.EnableCapabilities = true;
              _connection.ClientVersion = "1.0";
              _connection.Capabilities.Node = "http://www.ag-software.net/miniclient/caps";


              SetDiscoInfo();

              this.DialogResult = DialogResult.OK;

              SaveSettings();

              this.Close();

 and debug informaiton
SEND: <stream:stream to='ns3.anasel.com' xmlns='jabber:client' xmlns:stream='http://etherx.jabber.org/streams' version='1.0' xml:lang='en'>
RECV: <stream:stream xmlns:stream="http://etherx.jabber.org/streams" from="esx10-2022" version="1.0" xml:lang="en" id="255b3901" >
RECV: <stream:features xmlns:stream="http://etherx.jabber.org/streams"><mechanisms xmlns="urn:ietf:params:xml:ns:xmpp-sasl"><mechanism>DIGEST-MD5</mechanism><mechanism>PLAIN</mechanism><mechanism>ANONYMOUS</mechanism><mechanism>CRAM-MD5</mechanism></mechanisms><compression xmlns="http://jabber.org/features/compress"><method>zlib</method></compression><auth xmlns="http://jabber.org/features/iq-auth" /><register xmlns="http://jabber.org/features/iq-register" /></stream:features>
SEND: <auth xmlns="urn:ietf:params:xml:ns:xmpp-sasl" mechanism="DIGEST-MD5" />
RECV: <challenge xmlns="urn:ietf:params:xml:ns:xmpp-sasl">cmVhbG09ImVzeDEwLTIwMjIiLG5vbmNlPSJZcEJqTmVxMjFqMkV1MXlKVHhVSmJUdXVveVdtd2FoUG9xVUc3bklNIixxb3A9ImF1dGgiLGNoYXJzZXQ9dXRmLTgsYWxnb3JpdGhtPW1kNS1zZXNz</challenge>
SEND: <response xmlns="urn:ietf:params:xml:ns:xmpp-sasl">dXNlcm5hbWU9ImhodFw0MGVzeDEwLTIwMjIiLHJlYWxtPSJlc3gxMC0yMDIyIixub25jZT0iWXBCak5lcTIxajJFdTF5SlR4VUpiVHV1b3lXbXdhaFBvcVVHN25JTSIsY25vbmNlPSIwYTE5Zjk0ZWZjNzMyY2M2M2Q5YjkzOWQ4OWRkNzRiYzNkZWI1OThhYTI2NTdiYWZiZjEyNWE2YTIzMmVhOGRlIixuYz0wMDAwMDAwMSxxb3A9YXV0aCxkaWdlc3QtdXJpPSJ4bXBwL25zMy5hbmFzZWwuY29tIixjaGFyc2V0PXV0Zi04LHJlc3BvbnNlPWE4NmE4ZDg2OGVkNjJhZWFjNWNmNTNkZjM3MzgzYTk0</response>
RECV: <failure xmlns="urn:ietf:params:xml:ns:xmpp-sasl"><not-authorized /></failure>
SEND: </stream:stream>
RECV: </stream:stream>

  i'm tryin SSL 5223 and not SSL 5222 same error code.
  Thanks.
Avatar
Alex #9
Member since Feb 2003 · 4297 posts · Location: Germany
Group memberships: Administrators, Members
Show profile · Link to this post
this is an authentication problem. I assume the domain in your server configuration is wrong or does not match.
You can find the same problem here several times in the forums.

Alex
Avatar
javanesevn #10
Member since Apr 2008 · 74 posts · Location: Japan
Group memberships: Members
Show profile · Link to this post
In reply to post #8
Hi Cvg,

You can check these configurations:
 1  At Server Information  - Environment : it should be your host name ( not localhost)
 2. At Server Certificates : it should be your host name and domain name. In case "Jetty restart link" occur, please click on it to force restart jetty again.

HTH
Close Smaller – Larger + Reply to this post:
Verification code: VeriCode Please enter the word from the image into the text field below. (Type the letters only, lower case is okay.)
Smileys: :-) ;-) :-D :-p :blush: :cool: :rolleyes: :huh: :-/ <_< :-( :'( :#: :scared: 8-( :nuts: :-O
Special characters:
Forum: agsXMPP RSS