Not logged in. · Lost password · Register
Forum: agsXMPP RSS
Avatar
endy #1
Member since Nov 2008 · 2 posts
Group memberships: Members
Show profile · Link to this post
Subject: fastest way to find problem with connection
Hi,
I am creating visual basic 2005 application that should communicate with me via Gtalk.
Everything is fine, as long as I build the application and copy it to target server, where it is suppose to work.
However, my problem is, that when I add new features to the application, I debug things on my PC.
And here comes the problem, application is able to log in to gtalk only first few times and then it refuses to log in to gtalk.
And the user is offline..
Is there any way to find out, why gmail won't allow user to sign in on my PC?
I thought it is because when I debug application i go online/offline couple of times, but it is not too often.
Is there any way to see the reason which I would probably got from gmail when trying to connect why it won't sign me in ?
Login/password and other settings is fine I think, because as I mentioned, first few times it goes OK.. then after some time it isn't.
Thanks for advices,
endy
Avatar
Alex #2
Member since Feb 2003 · 4297 posts · Location: Germany
Group memberships: Administrators, Members
Show profile · Link to this post
Try to trace the Xml, Its possible that there is the reason in the Xml log when GTalk disconnects you.
Also subscribe to all error events in agsXMPP. Are you running the latest code from SVN?

Alex
Avatar
endy #3
Member since Nov 2008 · 2 posts
Group memberships: Members
Show profile · Link to this post
Hi  Alex,
thanks for quick response, I had no idea of any XML tracing.. would you please mind to point me where should I be looking for it ?
Thanks a lot.
Regarding the SVN, nope, I am not getting latestest source code yet, I am kind of a simple programmer and just using all the things the easiest way possible. Actually I have no idea how to work with sources from SVN :) but i'll get to that too..
thanks again.
endy
Avatar
Alex #4
Member since Feb 2003 · 4297 posts · Location: Germany
Group memberships: Administrators, Members
Show profile · Link to this post
Look at the OnReadXml and OnWriteXml events to trace the Xml which passes the wire.

There was a bug in the socket class which caused reconnect problems under some conditions.
See here:
http://forum.ag-software.de/forum.php?req=thread&id=679

Alex
Close Smaller – Larger + Reply to this post:
Verification code: VeriCode Please enter the word from the image into the text field below. (Type the letters only, lower case is okay.)
Smileys: :-) ;-) :-D :-p :blush: :cool: :rolleyes: :huh: :-/ <_< :-( :'( :#: :scared: 8-( :nuts: :-O
Special characters:
Forum: agsXMPP RSS