Not logged in. · Lost password · Register
Forum: agsXMPP SDK Support RSS
Avatar
dits59 #1
Member since Nov 2007 · 3 posts
Group memberships: Members
Show profile · Link to this post
Subject: Problem with basic code
Hi

i thank for the SDK,its really amazing...

bt im unable to explore into it.Stuck initially wit an error for ur basic code.

I added the dll AgsXMPP.ddl and try to send the message.Also added the libs
using agsXMPP;
using agsXMPP.Xml;
using agsXMPP.Xml.Dom;
using agsXMPP.protocol.client;


XmppClientConnection xmpp = new XmppClientConnection("jabber.org");
xmpp.Open("myusername", "mysecret");
xmpp.OnLogin += delegate(object o) { xmpp.Send(new Message("test@jabber.org", MessageType.chat, "Hello, how are you?")); };

atlast i found the prob: tat the Message might be interrupting wit windows message class.

so i used agsXMPP.protocol.client.Message instead of message .The error is gone..
bt authentication is false while i debug it.
Avatar
Alex #2
Member since Feb 2003 · 4245 posts · Location: Germany
Group memberships: Administrators, Members
Show profile · Link to this post
and what is your problem now? Please elaborate.

Alex
Alexander Gnauck
AG-Software
Avatar
dits59 #3
Member since Nov 2007 · 3 posts
Group memberships: Members
Show profile · Link to this post
i experimented with client only..i need to login to another jabber server [talk.google.com or jwchat.org or any]using the MiniClient [C# 2005].Bt its not working..i logged as a jabber user[either using jwchat.org or google account]Bt i am unable to send message to my google or any jabber account.
while i debug i found that authentication remains false after execution.
This post was edited on 2007-11-15, 06:05 by dits59.
Avatar
Alex #4
Member since Feb 2003 · 4245 posts · Location: Germany
Group memberships: Administrators, Members
Show profile · Link to this post
can you please post your XML logfiles here?

Thanks
Alex
Alexander Gnauck
AG-Software
Avatar
dits59 #5
Member since Nov 2007 · 3 posts
Group memberships: Members
Show profile · Link to this post
its working..
the prob is with sockets..
Avatar
rnbguy #6
Member since Dec 2007 · 3 posts
Group memberships: Members
Show profile · Link to this post
could you please share how u fixed this problem?
Close Smaller – Larger + Reply to this post:
Verification code: VeriCode Please enter the word from the image into the text field below. (Type the letters only, lower case is okay.)
Smileys: :-) ;-) :-D :-p :blush: :cool: :rolleyes: :huh: :-/ <_< :-( :'( :#: :scared: 8-( :nuts: :-O
Special characters:
Forum: agsXMPP SDK Support RSS