Not logged in. · Lost password · Register
Forum: agsXMPP RSS
Avatar
netlm #1
Member since Sep 2006 · 6 posts
Group memberships: Members
Show profile · Link to this post
Subject: The Server Can't route
I want to Transfer file between client1 and client2,but the server cat't route

I don't know do it ,so please help me .Thank you
Avatar
yeawsing #2
Member since Jul 2006 · 33 posts · Location: South Korea
Group memberships: Members
Show profile · Link to this post
Hi netlm,

What IM server are u using?

agsxmpp and Wildfire work together very well.  Wildfire include a proxy server and u can configure in the Admin page.
I am still learning..., hope I can contribute back.
YS
Avatar
netlm #3
Member since Sep 2006 · 6 posts
Group memberships: Members
Show profile · Link to this post
I used agsXMPP
Avatar
yeawsing #4
Member since Jul 2006 · 33 posts · Location: South Korea
Group memberships: Members
Show profile · Link to this post
I want to Transfer file between client1 and client2,but the server cat't route

Are u using a public server?  If so, then u need to check is the public server support filetransfer or not.  But I am not sure are u able to do a Disco or not.
If yes, then u need to find out their proxy.  Sometime those public server might require a login id and password.

Once u have those info, then put all this info into your clients.
I am still learning..., hope I can contribute back.
YS
Avatar
netlm #5
Member since Sep 2006 · 6 posts
Group memberships: Members
Show profile · Link to this post
ERROR :
Bad response received from proxy server

I am used is not public server,the receive Client  Auto Closed when the Error happend.

this is Send Client:
SEND: <iq xmlns="jabber:client" id="agsXMPP_6" to="test@localhost/" type="set"><si xmlns="http://jabber.org/protocol/si" profile="http://jabber.org/protocol/si/profile/file-transfer" id="b3b5f49c-8a94-49e2-908a-3de694b98af0"><file xmlns="http://jabber.org/protocol/si/profile/file-transfer" name="MiniClient.exe.config" size="382"><range /></file><feature xmlns="http://jabber.org/protocol/feature-neg"><x xmlns="jabber:x:data" type="form"><field type="list-single" var="stream-method"><option><value>http://jabber.org/protocol/bytestreams</value></option></field></x></feature></si></iq>
RECV: <iq xmlns="jabber:client" to="shumi@localhost" type="result" id="agsXMPP_6"><si xmlns="http://jabber.org/protocol/si" id="b3b5f49c-8a94-49e2-908a-3de694b98af0"><feature xmlns="http://jabber.org/protocol/feature-neg"><x xmlns="jabber:x:data" type="submit"><field var="stream-method"><value>http://jabber.org/protocol/bytestreams</value></field></x></feature></si></iq>
SEND: <iq xmlns="jabber:client" id="agsXMPP_7" to="test@localhost/" type="set"><query xmlns="http://jabber.org/protocol/bytestreams" sid="b3b5f49c-8a94-49e2-908a-3de694b98af0"><streamhost jid="shumi@localhost/MiniClient" host="10.194.85.36" port="1000" /><streamhost jid="proxy.ag-software.de" host="proxy.ag-software.de" port="7777" /></query></iq>
This post was edited on 2006-09-21, 07:44 by netlm.
Avatar
Jabberer #6
Member since Feb 2006 · 249 posts
Group memberships: Members
Show profile · Link to this post
your to address is wrong because it contains no resource.

SEND: <iq xmlns="jabber:client" id="agsXMPP_6" to="test@localhost/"
Software Developer
AG-Software
Avatar
netlm #7
Member since Sep 2006 · 6 posts
Group memberships: Members
Show profile · Link to this post
sorry ,this is i write wrong.i changed
Avatar
Jabberer #8
Member since Feb 2006 · 249 posts
Group memberships: Members
Show profile · Link to this post
also the proxy JID is set to our proxy (proxy.ag-software.de). If you want to test with your local server and proxy you also whould use your proxy instead of ours.
Software Developer
AG-Software
Avatar
netlm #9
Member since Sep 2006 · 6 posts
Group memberships: Members
Show profile · Link to this post
I do not have PROXY,

Can i not used proxy???
Avatar
Alex #10
Member since Feb 2003 · 4317 posts · Location: Germany
Group memberships: Administrators, Members
Show profile · Link to this post
in your code you offer 2 streamhosts:

  1. <streamhost jid="shumi@localhost/MiniClient" host="10.194.85.36" port="1000" />
  2. <streamhost jid="proxy.ag-software.de" host="proxy.ag-software.de" port="7777" />

and the second one is a proxy.
Please read the JEP-0065 and all other Threads in this forum about SOCKS5 file transfers.

Alex
Close Smaller – Larger + Reply to this post:
Verification code: VeriCode Please enter the word from the image into the text field below. (Type the letters only, lower case is okay.)
Smileys: :-) ;-) :-D :-p :blush: :cool: :rolleyes: :huh: :-/ <_< :-( :'( :#: :scared: 8-( :nuts: :-O
Special characters:
Forum: agsXMPP RSS