Not logged in. · Lost password · Register
Forum: XMPP Protocol RSS
Page: previous  1  2  3  4  next
Avatar
Alex #31
Member since Feb 2003 · 4327 posts · Location: Germany
Group memberships: Administrators, Members
Show profile · Link to this post
In reply to post ID 1176
look at the StreamHost class. There you will find the Host property.

Alex
Avatar
scharfed #32
Member since Jul 2006 · 33 posts
Group memberships: Members
Show profile · Link to this post
Alex,

I changed the host property so that it will always match the proxy JID, but I think the wildfire server is sending a different host name as a response.  I took a screenshot of my wildfire admin screen to show you what I am talking about.

Notice the 127.0.1.1

[Image: http://filebox.vt.edu/users/scharf/WF.JPG]
Avatar
Alex #33
Member since Feb 2003 · 4327 posts · Location: Germany
Group memberships: Administrators, Members
Show profile · Link to this post
the 127.0.0.1 is OK. Wildfire automatically shows the IP of your machine. I invite you again to create a account on our server and use it for your testing.

Alex
Avatar
scharfed #34
Member since Jul 2006 · 33 posts
Group memberships: Members
Show profile · Link to this post
Thanks Alex.  I will do that until I can figure out the problem on my end. :)
Avatar
scharfed #35
Member since Jul 2006 · 33 posts
Group memberships: Members
Show profile · Link to this post
Where can I create the account?  proxy.ag-software.de does not give me an option to create one
Avatar
Alex #36
Member since Feb 2003 · 4327 posts · Location: Germany
Group memberships: Administrators, Members
Show profile · Link to this post
the server is available under ag-software.de. You should be able to create a account with any jabber
Here is a list of available jabber clients:
http://www.jabber.org/software/clients.shtml

Alex
Avatar
scharfed #37
Member since Jul 2006 · 33 posts
Group memberships: Members
Show profile · Link to this post
In reply to post ID 1170
Quote by scharfed on 2006-07-20, 22:35:
No worries, now we are getting somewhere :)

SEND: <iq xmlns="jabber:client" id="agsXMPP_6" type="get" to="proxy.192.168.10.71"><query xmlns="http://jabber.org/protocol/bytestreams" /></iq>
SEND: <iq xmlns="jabber:client" id="agsXMPP_7" type="set" to="ascharf@192.168.10.71/Spark"><query xmlns="http://jabber.org/protocol/bytestreams" mode="tcp" sid="s5b_8c87a26e3392f28"><streamhost jid="proxy.192.168.10.71" host="127.0.1.1" port="7777" /></query></iq>
RECV: <iq xmlns="jabber:client" from="proxy.192.168.10.71" to="jshaffer@192.168.10.71/MiniClient" type="result" id="agsXMPP_6"><query xmlns="http://jabber.org/protocol/bytestreams"><streamhost port="7777" jid="proxy.192.168.10.71" host="proxy.206.158.107.6" /></query></iq>
RECV: <iq xmlns="jabber:client" from="ascharf@192.168.10.71/Spark" to="jshaffer@192.168.10.71/MiniClient" type="error" id="agsXMPP_7"><error code="406" /></iq>

Alex,

I am still having this problem.  No matter which client I use, it is unable to connect to the offered streamhosts.  the 206.158.107.6 is the outside IP address of the wildfire server, while the 192.168.10.71 is the local IP.  Do you have any more suggestions to why a connection cannot be made?

Thanks
Avatar
Alex #38
Member since Feb 2003 · 4327 posts · Location: Germany
Group memberships: Administrators, Members
Show profile · Link to this post
Hello,

I assume the debug from an attempt of sending an file to another user.
Look at the second packet you send. Host is there 127.0.0.1, but it should be one of the IP's 206.158.107.6, 192.168.10.71. But i can't connect to your external IP on port 7777. So this IP is configured not correctly in your firewall or router.
You also should change the order of the packets you send. But this is not related to your problem. The first query you send is getting the information (host and port) from your proxy. And this is the data which you should include with your second packet which offers the streamhost(s). So you should wait until you get the response of your first query, and use this information for building your second packet. The best is to use an IQGrabber for sending this packets.

Alex
Avatar
scharfed #39
Member since Jul 2006 · 33 posts
Group memberships: Members
Show profile · Link to this post
Try connecting to it now.  The port is open for external access
Avatar
Alex #40
Member since Feb 2003 · 4327 posts · Location: Germany
Group memberships: Administrators, Members
Show profile · Link to this post
i get errors when i try to use your our code or PSI on your server. The config of your server must be wrong.
Did you try our server and our proxy?

Alex
Avatar
scharfed #41
Member since Jul 2006 · 33 posts
Group memberships: Members
Show profile · Link to this post
Everything seems to be configured correctly in the Wildfire admin console.  Are there any specific settings I should set other than:

1) enabling file transfer proxy on port 7777?
2) enabling s2s?

I am curious because I am able to use Spark to send and recieve messages using my Wildfire server, but not with the MiniClient.  That is why I can only assume the issue is in the code.
Avatar
Alex #42
Member since Feb 2003 · 4327 posts · Location: Germany
Group memberships: Administrators, Members
Show profile · Link to this post
[2006-07-24 22:51:32.156]  Looking up SRV: _xmpp-client._tcp.206.158.107.6
[2006-07-24 22:51:32.265]  Direct DNS failed.. Using server: 206.158.107.6
[2006-07-24 22:51:32.390]  SENT: <stream:stream to="206.158.107.6" xmlns="jabber:client" xmlns:stream="http://etherx.jabber.org/streams"  xml:lang="de_DE" version="1.0" >
[2006-07-24 22:51:32.531]  RECV: <?xml version='1.0' encoding='UTF-8'?><stream:stream xmlns:stream="http://etherx.jabber.org/streams" xmlns="jabber:client" from="192.168.10.71" id="fce25083" xml:lang="de_DE" version="1.0"><stream:features><starttls xmlns="urn:ietf:params:xml:ns:xmpp-tls"></starttls><mechanisms xmlns="urn:ietf:params:xml:ns:xmpp-sasl"><mechanism>PLAIN</mechanism><mechanism>CRAM-MD5</mechanism><mechanism>DIGEST-MD5</mechanism><mechanism>ANONYMOUS</mechanism></mechanisms><auth xmlns="http://jabber.org/features/iq-auth"/><register xmlns="http://jabber.org/features/iq-register"/></stream:features>

as you can see in my debug the server responds with another IP adress.
to="206.158.107.6"
from="192.168.10.71"


please configure your server to a real domain whiich resolvs to your external IP.

Alex
Avatar
scharfed #43
Member since Jul 2006 · 33 posts
Group memberships: Members
Show profile · Link to this post
Okay, turns out my issue is with port forwarding.  I will talk to our server admin.

Thanks
Avatar
Alex #44
Member since Feb 2003 · 4327 posts · Location: Germany
Group memberships: Administrators, Members
Show profile · Link to this post
one IP is the internal one and the other is the extenal. All you need is a domain name and it should work
Avatar
scharfed #45
Member since Jul 2006 · 33 posts
Group memberships: Members
Show profile · Link to this post
Got a domain name: rali.shepherdmed.com

Here is the debug now.

SEND: <iq xmlns="jabber:client" id="agsXMPP_6" type="set" to="ascharf@rali.shepherdmed.com/Spark"><si xmlns="http://jabber.org/protocol/si" profile="http://jabber.org/protocol/si/profile/file-transfer" id="s5b_8c87eef31596882"><file xmlns="http://jabber.org/protocol/si/profile/file-transfer" name="license.txt" size="15883"><desc /></file><feature xmlns="http://jabber.org/protocol/feature-neg"><x xmlns="jabber:x:data" type="form"><field type="list-single" var="stream-method"><option><value>http://jabber.org/protocol/bytestreams</value></option></field></x></feature></si></iq>

RECV: <iq id="agsXMPP_6" to="jshaffer@rali.shepherdmed.com/MiniClient" from="ascharf@rali.shepherdmed.com/Spark" type="result"><si xmlns="http://jabber.org/protocol/si"><feature xmlns="http://jabber.org/protocol/feature-neg"><x xmlns="jabber:x:data" type="submit"><field var="stream-method"><value>http://jabber.org/protocol/bytestreams</value></field></x></feature></si></iq>

SEND: <iq xmlns="jabber:client" id="agsXMPP_7" type="get" to="proxy.rali.shepherdmed.com"><query xmlns="http://jabber.org/protocol/bytestreams" /></iq>

SEND: <iq xmlns="jabber:client" id="agsXMPP_8" type="set" to="ascharf@rali.shepherdmed.com/Spark"><query xmlns="http://jabber.org/protocol/bytestreams" mode="tcp" sid="s5b_8c87eef31596882"><streamhost jid="proxy.rali.shepherdmed.com" host="proxy.rali.shepherdmed.com" port="7777" /></query></iq>

RECV: <iq type="result" id="agsXMPP_7" from="proxy.rali.shepherdmed.com" to="jshaffer@rali.shepherdmed.com/MiniClient"><query xmlns="http://jabber.org/protocol/bytestreams"><streamhost jid="proxy.rali.shepherdmed.com" host="proxy.206.158.107.6" port="7777"/></query></iq>

RECV: <iq id="agsXMPP_8" to="jshaffer@rali.shepherdmed.com/MiniClient" from="ascharf@rali.shepherdmed.com/Spark" type="error"><error code="406"/></iq>

The host is coming back as proxy.206.158.107.6 and I dont know why :(
Close Smaller – Larger + Reply to this post:
Verification code: VeriCode Please enter the word from the image into the text field below. (Type the letters only, lower case is okay.)
Smileys: :-) ;-) :-D :-p :blush: :cool: :rolleyes: :huh: :-/ <_< :-( :'( :#: :scared: 8-( :nuts: :-O
Special characters:
Page: previous  1  2  3  4  next