Not logged in. · Lost password · Register
Forum: MatriX RSS
Avatar
sasharp #1
Member since Nov 2017 · 6 posts
Group memberships: Members
Show profile · Link to this post
Subject: Xamarin vs. Matrix vNext
Hello, it is possible to run Matrix vNext on Xamarin? I am asking because Xamarin now supports .Net Standard, which supports .Net Core. I could install Matrix vNext on Xamarin.Forms, but I can't get connected with server. There was more Exceptions.
Avatar
Alex #2
Member since Feb 2003 · 4327 posts · Location: Germany
Group memberships: Administrators, Members
Show profile · Link to this post
I have not tried the latest Xamarin versions for netStandard myself for a while.
Xamarin seems to implement the netStandard up to 2.0 now. So it should work fine.

Please report your findings.

Alex
This post was edited on 2017-11-15, 14:26 by Alex.
Avatar
sasharp #3
Member since Nov 2017 · 6 posts
Group memberships: Members
Show profile · Link to this post
Yes! It works!

There was problems with secured connection on my side.

Tested on Xamarin.Forms UWP
Avatar
sasharp #4
Member since Nov 2017 · 6 posts
Group memberships: Members
Show profile · Link to this post
In reply to post #2
I am trying further to develop with Matrix vNet on Xamarin...

When I call under UWP x86

  1. await xmppClient.SendAsync(msg);

the message will arrived and it holds with System.AccessViolationException

Under UWP x64 there is no exeption and works fine.
This post was edited on 2017-11-26, 11:31 by Alex.
Avatar
Alex #5
Member since Feb 2003 · 4327 posts · Location: Germany
Group memberships: Administrators, Members
Show profile · Link to this post
Do you have a complete stacktrace to see where this is happening?
Also a complete XML log.
Avatar
sasharp #6
Member since Nov 2017 · 6 posts
Group memberships: Members
Show profile · Link to this post
Quote by Alex:
Do you have a complete stacktrace to see where this is happening?
Also a complete XML log.
There is no fields in Call Stack.

All I can see is:
An unhandled exception of type 'System.AccessViolationException' occurred in Unknown Module.
Attempted to read or write protected memory. This is often an indication that other memory is corrupt. occurred
Avatar
Alex #7
Member since Feb 2003 · 4327 posts · Location: Germany
Group memberships: Administrators, Members
Show profile · Link to this post
I cannot reproduce your issue. I tested with an UWP app where Platform target is x86 and it works fine here.
Platform version is 10.0.16299.0
Avatar
sasharp #8
Member since Nov 2017 · 6 posts
Group memberships: Members
Show profile · Link to this post
BTW tested on Xamarin.iOS - works also!
This post was edited on 2017-12-01, 08:28 by sasharp.
Avatar
sasharp #9
Member since Nov 2017 · 6 posts
Group memberships: Members
Show profile · Link to this post
In reply to post #7
Quote by Alex on 2017-11-29, 10:42:
I cannot reproduce your issue. I tested with an UWP app where Platform target is x86 and it works fine here.
Platform version is 10.0.16299.0
Unfortunately I get still the exception. I develop under Parallels on Mac, maybe that is the reason. Platform version is the same.
Close Smaller – Larger + Reply to this post:
Verification code: VeriCode Please enter the word from the image into the text field below. (Type the letters only, lower case is okay.)
Smileys: :-) ;-) :-D :-p :blush: :cool: :rolleyes: :huh: :-/ <_< :-( :'( :#: :scared: 8-( :nuts: :-O
Special characters:
Forum: MatriX RSS