Not logged in. · Lost password · Register
Forum: agsXMPP RSS
Avatar
fr3akb0y #1
Member since Sep 2017 · 7 posts
Group memberships: Members
Show profile · Link to this post
Subject: Sasl Challenge Fails for Newly Registered Accounts
x
This post was edited 2 times, last on 2017-09-06, 20:52 by fr3akb0y.
Avatar
fr3akb0y #2
Member since Sep 2017 · 7 posts
Group memberships: Members
Show profile · Link to this post
x
This post was edited 2 times, last on 2017-09-06, 20:52 by fr3akb0y.
Avatar
Alex #3
Member since Feb 2003 · 4327 posts · Location: Germany
Group memberships: Administrators, Members
Show profile · Link to this post
I think the problem is that the server does not send the realm in digest md5 step1.
Try to fetch and compile the latest sources. This should be fixed there.
Avatar
fr3akb0y #4
Member since Sep 2017 · 7 posts
Group memberships: Members
Show profile · Link to this post
i didn't get what you said.

Should i go with step 2 ?
Avatar
Alex #5
Member since Feb 2003 · 4327 posts · Location: Germany
Group memberships: Administrators, Members
Show profile · Link to this post
you should:

  • download the latest agsXMPP sources from SVN
  • compile a new dl
  • include it in your project
  • try again
Avatar
fr3akb0y #6
Member since Sep 2017 · 7 posts
Group memberships: Members
Show profile · Link to this post
Thank You,
if you don't mind can i have a link ?
I'm not familiar with online repositories
Edit: I got the link

So you says this will work fine on latest build ?

Edit2 : I downloaded and build, Same issue again :(
This post was edited on 2017-09-06, 19:19 by fr3akb0y.
Avatar
Alex #7
Member since Feb 2003 · 4327 posts · Location: Germany
Group memberships: Administrators, Members
Show profile · Link to this post
you can find the link to the SVN Repo on this page:
https://www.ag-software.net/agsxmpp-sdk/download/

Please post your logs again when you are running with the latest code.
This post was edited on 2017-09-06, 19:32 by Alex.
Avatar
fr3akb0y #8
Member since Sep 2017 · 7 posts
Group memberships: Members
Show profile · Link to this post
x
This post was edited 2 times, last on 2017-09-06, 20:52 by fr3akb0y.
Avatar
Alex #9
Member since Feb 2003 · 4327 posts · Location: Germany
Group memberships: Administrators, Members
Show profile · Link to this post
sorry, but I don't see why it would fail from the logs.
I assume you would have to ask nimbuzz if they have changed anything on the server. If yes we need more info on the details.

I see no differences between the success and failure logs.
You can try yourself, maybe you see something, just base64 decode the value of the challenge and response xml tags and you get the Raw Sasl messages.
Avatar
fr3akb0y #10
Member since Sep 2017 · 7 posts
Group memberships: Members
Show profile · Link to this post
They changed settings, But not for everyone, only for newly created accounts or accounts that changed password recently

But all accounts works fine on other clients like JAJC
This post was edited on 2017-09-06, 20:06 by fr3akb0y.
Avatar
fr3akb0y #11
Member since Sep 2017 · 7 posts
Group memberships: Members
Show profile · Link to this post
is there anyway to decode cnonce and response values ?
Close Smaller – Larger + Reply to this post:
Verification code: VeriCode Please enter the word from the image into the text field below. (Type the letters only, lower case is okay.)
Smileys: :-) ;-) :-D :-p :blush: :cool: :rolleyes: :huh: :-/ <_< :-( :'( :#: :scared: 8-( :nuts: :-O
Special characters:
Forum: agsXMPP RSS