Not logged in. · Lost password · Register
Forum: agsXMPP RSS
First agsXMPP.Net.Dns.NoResponseException and then agsXMPP.Net.ConnectTimeoutException?
Avatar
Maciej #1
Member since Jul 2012 · 12 posts
Group memberships: Members
Show profile · Link to this post
Subject: agsXMPP.Net.ConnectTimeoutException and out of ideas for debugging
Dear agsXMPP support and all agsXMPP users,

I have a strange problem with one of my customers and I am trying to debug it.
The customer was getting the following exception.

[14:41:47.752 D] [Sharp Messenger DE] Messaging error 'agsXMPP.Net.Dns.NoResponseException: Systemfehler
   bei agsXMPP.Net.Dns.Resolver.UdpTransfer(IPEndPoint server, Byte[] requestMessage)
   bei agsXMPP.Net.Dns.Resolver.Lookup(Request request, IPAddress dnsServer)
   bei agsXMPP.Net.Dns.Resolver.SRVLookup(String domain, IPAddress dnsServer)
   bei agsXMPP.XmppClientConnection.ResolveSrv()'.

I am using agsXMPP with already built in IPv6 support but the exception was coming until my client disabled IPv6 on his Windows 7 machine. Now he is getting the following exception.

[16:09:50.591 D] [Sharp Messenger] Messaging socket error 'agsXMPP.Net.ConnectTimeoutException: Attempt to connect timed out'. Firewall blocking port 5222?

We were trying do disable the firewalls (Windows and his router) and Windows Security Essentials but nothing works. He is able to execute telnet xmpp.l.google.com for port 5222 and to do a nslookup on google.de and google.com.

The last ipconfig /all output is as follows.

C:\Windows\system32>ipconfig /all

Windows-IP-Konfiguration

Hostname . . . . . . . . . . . . : Kama-PC
Primäres DNS-Suffix . . . . . . . :
Knotentyp . . . . . . . . . . . . : Hybrid
IP-Routing aktiviert . . . . . . : Nein
WINS-Proxy aktiviert . . . . . . : Nein

Ethernet-Adapter LAN-Verbindung:

Verbindungsspezifisches DNS-Suffix:
Beschreibung. . . . . . . . . . . : NVIDIA nForce 10/100 Mbps Ethernet
Physikalische Adresse . . . . . . : 00-25-22-71-6B-C2
DHCP aktiviert. . . . . . . . . . : Ja
Autokonfiguration aktiviert . . . : Ja
IPv4-Adresse . . . . . . . . . . : 192.168.0.101(Bevorzugt)
Subnetzmaske . . . . . . . . . . : 255.255.255.0
Lease erhalten. . . . . . . . . . : Freitag, 21. März 2014 13:58:59
Lease läuft ab. . . . . . . . . . : Samstag, 22. März 2014 13:58:59
Standardgateway . . . . . . . . . : 192.168.0.1
DHCP-Server . . . . . . . . . . . : 192.168.0.1
DNS-Server . . . . . . . . . . . : 192.168.0.1
NetBIOS über TCP/IP . . . . . . . : Aktiviert

Tunneladapter isatap.{911EDDB6-193C-428D-8D0D-E60B42871B62}:

Medienstatus. . . . . . . . . . . : Medium getrennt
Verbindungsspezifisches DNS-Suffix:
Beschreibung. . . . . . . . . . . : Microsoft-ISATAP-Adapter
Physikalische Adresse . . . . . . : 00-00-00-00-00-00-00-E0
DHCP aktiviert. . . . . . . . . . : Nein
Autokonfiguration aktiviert . . . : Ja

I think that DNS lookups may still be failing because I am logging the server and it seems to be null the whole time.

[16:40:23.083 D] [Sharp Messenger] Server is '', port is '5222'.

Any ideas what to do next in order to debug it?
This post was edited on 2014-03-21, 18:26 by Maciej.
Avatar
Alex #2
Member since Feb 2003 · 4322 posts · Location: Germany
Group memberships: Administrators, Members
Show profile · Link to this post
looks like there is an exception in the DNS resolver when agsXMPP tries to lookup the SRV records for your XMPP domain.
SRV lookups are DNS queries on UDP.

Alex
Avatar
Maciej #3
Member since Jul 2012 · 12 posts
Group memberships: Members
Show profile · Link to this post
Yes, that's correct. However I have no idea how to support the customer in solving that.
Why is the SRV lookup failing if the customer is able to execute nslookup?
What would be next steps to debug it? Any idea?
Avatar
Alex #4
Member since Feb 2003 · 4322 posts · Location: Germany
Group memberships: Administrators, Members
Show profile · Link to this post
the SRV lookups are required in XMPP for resolving the correct hostname of the XMPP server.
Right now I have no idea, such an issue came not up before. This is something we would have to debug.

Alex
Avatar
Alex #5
Member since Feb 2003 · 4322 posts · Location: Germany
Group memberships: Administrators, Members
Show profile · Link to this post
when your service is not using SRV records you can try to disable SRV resolving (m_AutoResolveConnectServer = false).

Alex
Avatar
Maciej #6
Member since Jul 2012 · 12 posts
Group memberships: Members
Show profile · Link to this post
Well actually I would like to keep SRV resolving. My customers are connecting to Google Talk servers.
How would you debug the issue?
Avatar
Alex #7
Member since Feb 2003 · 4322 posts · Location: Germany
Group memberships: Administrators, Members
Show profile · Link to this post
I can only debug only problems which I can reproduce on my machine.

Alex
Avatar
Maciej #8
Member since Jul 2012 · 12 posts
Group memberships: Members
Show profile · Link to this post
Well it's impossible to replicate customers environment to you so that would mean I am lost/on my own ;)
Close Smaller – Larger + Reply to this post:
Verification code: VeriCode Please enter the word from the image into the text field below. (Type the letters only, lower case is okay.)
Smileys: :-) ;-) :-D :-p :blush: :cool: :rolleyes: :huh: :-/ <_< :-( :'( :#: :scared: 8-( :nuts: :-O
Special characters:
Forum: agsXMPP RSS