Not logged in. · Lost password · Register
Forum: MatriX RSS
Avatar
void_alex #1
Member since Jan 2014 · 6 posts
Group memberships: Members
Show profile
Subject: Auth error during the certificate validation
  1. var xmppClient = new XmppClient { XmppDomain = "somedomain.com", Username = "username", Password = "password" };
  2. xmppClient.OnValidateCertificate += delegate(object sender, CertificateEventArgs eventArgs)
  3. {
  4.     eventArgs.AcceptCertificate = true;  
  5. };
  6. xmppClient.Open();
OnAuthError event raises with the next message:
  1. <failure xmlns="urn:ietf:params:xml:ns:xmpp-sasl">
  2.  <not-authorized />
  3. </failure>
I've also tried to connect to the server with the Gajim client and with jabber-net library. They work fine. I noticed that Gajim and jabber-net offer to apply the certificate, but Matrix library does not.
This post was edited on 2014-01-24, 11:39 by Alex.
Avatar
Alex #2
Member since Feb 2003 · 4298 posts · Location: Germany
Group memberships: Administrators, Members
Show profile
Please post the complete Xml log, fro the beginning (<stream:stream/>) until your error occurs.
You can also attach a successful one from Gajim, so we can compare them.

Alex
Avatar
void_alex #3
Member since Jan 2014 · 6 posts
Group memberships: Members
Show profile
Matrix:
  1. Send:
  2. <stream:stream xmlns:stream="http://etherx.jabber.org/streams" xmlns="jabber:client" to="api.coredial.com" version="1.0" >
  3.  
  4. Receive:
  5. <stream:stream xmlns:stream="http://etherx.jabber.org/streams" xmlns="jabber:client" id="1604181620" from="api.coredial.com" version="1.0" xml:lang="en" >
  6.  
  7. Receive:
  8. <stream:features xmlns:stream="http://etherx.jabber.org/streams">
  9.  <starttls xmlns="urn:ietf:params:xml:ns:xmpp-tls" />
  10.  <mechanisms xmlns="urn:ietf:params:xml:ns:xmpp-sasl">
  11.     <mechanism>PLAIN</mechanism>
  12.  </mechanisms>
  13.  <c xmlns="http://jabber.org/protocol/caps" hash="sha-1" node="http://www.process-one.net/en/ejabberd/" ver="8P/XuMtKq0lNk50DLBC8v+TXoAU=" />
  14.  <register xmlns="http://jabber.org/features/iq-register" />
  15. </stream:features>
  16.  
  17. Send:
  18. <starttls xmlns="urn:ietf:params:xml:ns:xmpp-tls" />
  19.  
  20. Receive:
  21. <proceed xmlns="urn:ietf:params:xml:ns:xmpp-tls" />
  22.  
  23. Send:
  24. <stream:stream xmlns:stream="http://etherx.jabber.org/streams" xmlns="jabber:client" to="api.coredial.com" version="1.0" >
  25.  
  26. Receive:
  27. <stream:stream xmlns:stream="http://etherx.jabber.org/streams" xmlns="jabber:client" id="3163357646" from="api.coredial.com" version="1.0" xml:lang="en" >
  28.  
  29. Receive:
  30. <stream:features xmlns:stream="http://etherx.jabber.org/streams">
  31.  <mechanisms xmlns="urn:ietf:params:xml:ns:xmpp-sasl">
  32.     <mechanism>PLAIN</mechanism>
  33.  </mechanisms>
  34.  <c xmlns="http://jabber.org/protocol/caps" hash="sha-1" node="http://www.process-one.net/en/ejabberd/" ver="8P/XuMtKq0lNk50DLBC8v+TXoAU=" />
  35.  <register xmlns="http://jabber.org/features/iq-register" />
  36. </stream:features>
  37.  
  38. Send:
  39. <auth mechanism="PLAIN" xmlns="urn:ietf:params:xml:ns:xmpp-sasl">XXX</auth>
  40.  
  41. Receive:
  42. <failure xmlns="urn:ietf:params:xml:ns:xmpp-sasl">
  43.  <not-authorized />
  44. </failure>

Gajim:
  1. <!-- Out -->
  2. <?xml version='1.0'?>
  3. <stream:stream xmlns="jabber:client" to="api.coredial.com" version="1.0" xmlns:stream="http://etherx.jabber.org/streams" xml:lang="en" >
  4.  
  5. <!-- In -->
  6. <?xml version='1.0'?>
  7. <stream:stream xmlns='jabber:client' xmlns:stream='http://etherx.jabber.org/streams' id='1293121150' from='api.coredial.com' version='1.0' xml:lang='en'>
  8. <stream:features>
  9. <starttls xmlns='urn:ietf:params:xml:ns:xmpp-tls'/>
  10. <mechanisms xmlns='urn:ietf:params:xml:ns:xmpp-sasl'>
  11. <mechanism>PLAIN</mechanism>
  12. </mechanisms>
  13. <c xmlns='http://jabber.org/protocol/caps' hash='sha-1' node='http://www.process-one.net/en/ejabberd/' ver='8P/XuMtKq0lNk50DLBC8v+TXoAU='/>
  14. <register xmlns='http://jabber.org/features/iq-register'/>
  15. </stream:features>
  16.  
  17. <!-- Out -->
  18. <starttls xmlns="urn:ietf:params:xml:ns:xmpp-tls"/>
  19.  
  20. <!-- In -->
  21. <proceed xmlns='urn:ietf:params:xml:ns:xmpp-tls'/>
  22.  
  23. <!-- Out -->
  24. <?xml version='1.0'?>
  25. <stream:stream xmlns="jabber:client" to="api.coredial.com" version="1.0" xmlns:stream="http://etherx.jabber.org/streams" xml:lang="en" >
  26.  
  27. <!-- In -->
  28. <?xml version='1.0'?>
  29. <stream:stream xmlns='jabber:client' xmlns:stream='http://etherx.jabber.org/streams' id='1732781007' from='api.coredial.com' version='1.0' xml:lang='en'>
  30.  
  31. <!-- In -->
  32. <stream:features>
  33. <mechanisms xmlns='urn:ietf:params:xml:ns:xmpp-sasl'>
  34. <mechanism>PLAIN</mechanism>
  35. </mechanisms>
  36. <c xmlns='http://jabber.org/protocol/caps' hash='sha-1' node='http://www.process-one.net/en/ejabberd/' ver='8P/XuMtKq0lNk50DLBC8v+TXoAU='/>
  37. <register xmlns='http://jabber.org/features/iq-register'/>
  38. </stream:features>
  39.  
  40. <!-- Out -->
  41. <auth xmlns="urn:ietf:params:xml:ns:xmpp-sasl" mechanism="PLAIN">XXX</auth>
  42.  
  43. <!-- In -->
  44. <success xmlns='urn:ietf:params:xml:ns:xmpp-sasl'/>
This post was edited 3 times, last on 2014-01-24, 12:29 by Alex.
Avatar
Alex #4
Member since Feb 2003 · 4298 posts · Location: Germany
Group memberships: Administrators, Members
Show profile
oh, you are also using the coredial API. We just had the same discussion yesterday here:
http://forum.ag-software.net/thread/1646-unknown-host

there you should be able to find the correct settings for MatriX. If it does not work then please contact me directly by email.

Alex
Avatar
void_alex #5
Member since Jan 2014 · 6 posts
Group memberships: Members
Show profile
Thanks a lot! It works now. I also had to specify xmppClient.Hostname property.
Avatar
Alex #6
Member since Feb 2003 · 4298 posts · Location: Germany
Group memberships: Administrators, Members
Show profile
right, otherwise it resolves the Hostname automatically from SRV records and ignores the Hostname you set.
Close Smaller – Larger + Reply to this post:
Verification code: VeriCode Please enter the word from the image into the text field below. (Type the letters only, lower case is okay.)
Smileys: :-) ;-) :-D :-p :blush: :cool: :rolleyes: :huh: :-/ <_< :-( :'( :#: :scared: 8-( :nuts: :-O
Special characters:
Forum: MatriX RSS