Not logged in. · Lost password · Register
Forum: agsXMPP RSS
Avatar
St3v3 #1
Member since Oct 2013 · 6 posts
Group memberships: Members
Show profile · Link to this post
Subject: Client app connects to server OK on Vista Laptop but not on XP desk PC
My app connects well to lightwitch.org on my Vista laptop but when I moved the identical code to the XP desktop PC it fires xmppCon_OnError() and then OnClose(). The exception is "Received unexpected EOF or 0 bytes".

Strangely I can connect to Google talk from either PC which makes me think it may be a server side problem on lightwitch.org.
Is there something I can do to get this working?

The failed xml is:
  1. Send: <stream:stream to='lightwitch.org' xmlns='jabber:client' xmlns:stream='http://etherx.jabber.org/streams' version='1.0' xml:lang='en'>
  2. Recv: <stream:stream xmlns:stream="http://etherx.jabber.org/streams" xml:lang="en" id="46bc9777-8059-4f17-96cb-ad0c5aa2f04c" from="lightwitch.org" version="1.0" >
  3. Recv: <stream:features xmlns:stream="http://etherx.jabber.org/streams"><mechanisms xmlns="urn:ietf:params:xml:ns:xmpp-sasl"><mechanism>SCRAM-SHA-1</mechanism></mechanisms><starttls xmlns="urn:ietf:params:xml:ns:xmpp-tls" /></stream:features>
  4. Send: <starttls xmlns="urn:ietf:params:xml:ns:xmpp-tls" />
  5. Recv: <proceed xmlns="urn:ietf:params:xml:ns:xmpp-tls" />

Thanks.
Avatar
Alex #2
Member since Feb 2003 · 4327 posts · Location: Germany
Group memberships: Administrators, Members
Show profile · Link to this post
looks like its crashing on TLS negotiation.
Can you try to get the full stacktracke or debug the StartTls code?

may be also possible that the server wants to use crypto algorithms which are not supported on XP.
Close Smaller – Larger + Reply to this post:
Verification code: VeriCode Please enter the word from the image into the text field below. (Type the letters only, lower case is okay.)
Smileys: :-) ;-) :-D :-p :blush: :cool: :rolleyes: :huh: :-/ <_< :-( :'( :#: :scared: 8-( :nuts: :-O
Special characters:
Forum: agsXMPP RSS