Not logged in. · Lost password · Register
Forum: agsXMPP RSS
Avatar
Frayx #1
Member since Feb 2013 · 3 posts
Group memberships: Members
Show profile · Link to this post
Subject: Connect agsXMPP MiniClient to OpenFire 3.7.1
I'm trying to connect the miniclient to openfire but it says that the username or password is wrong even though I am sure that are right. debug output:

  1. SEND: <stream:stream to='mydomain.net' xmlns='jabber:client' xmlns:stream='http://etherx.jabber.org/streams' version='1.0' xml:lang='en'>
  2. RECV: <stream:stream xmlns:stream="http://etherx.jabber.org/streams" from="mydomain.net" xml:lang="en" version="1.0" id="2e312b6e" >
  3. RECV: <stream:features xmlns:stream="http://etherx.jabber.org/streams"><mechanisms xmlns="urn:ietf:params:xml:ns:xmpp-sasl"><mechanism>DIGEST-MD5</mechanism><mechanism>PLAIN</mechanism><mechanism>ANONYMOUS</mechanism><mechanism>CRAM-MD5</mechanism></mechanisms><compression xmlns="http://jabber.org/features/compress"><method>zlib</method></compression><auth xmlns="http://jabber.org/features/iq-auth" /><register xmlns="http://jabber.org/features/iq-register" /></stream:features>
  4. SEND: <auth xmlns="urn:ietf:params:xml:ns:xmpp-sasl" mechanism="DIGEST-MD5" />
  5. RECV: <challenge xmlns="urn:ietf:params:xml:ns:xmpp-sasl">cmVhbG09InRhY3RpY2xlZ2FtZS5jbG91ZGFwcC5uZXQiLG5vbmNlPSI3UTRwTkJaMm5NcVZzalBTSlNKQllEc2FkdWtuSk9saWd3ZnNlWTErIixxb3A9ImF1dGgiLGNoYXJzZXQ9dXRmLTgsYWxnb3JpdGhtPW1kNS1zZXNz</challenge>
  6. SEND: <response xmlns="urn:ietf:params:xml:ns:xmpp-sasl">dXNlcm5hbWU9InN0ZW11bGUiLHJlYWxtPSJ0YWN0aWNsZWdhbWUuY2xvdWRhcHAubmV0Iixub25jZT0iN1E0cE5CWjJuTXFWc2pQU0pTSkJZRHNhZHVrbkpPbGlnd2ZzZVkxKyIsY25vbmNlPSI0NzQ1ZTQ0ZTgyOWYzZGRkOTA2MzYwZGU5NWE1OWFhZDE0ODg2MzcyNGRlNDAzMjU4ODRjMjNjMTk0ODI4NGQ3IixuYz0wMDAwMDAwMSxxb3A9YXV0aCxkaWdlc3QtdXJpPSJ4bXBwL3RhY3RpY2FsZ2FtZS5jbG91ZGFwcC5uZXQiLGNoYXJzZXQ9dXRmLTgscmVzcG9uc2U9OWNlNzdlMzI1MWQ1MmIxYjA1ZDlkZmU5MjJlNzBiZWI=</response>
  7. RECV: <failure xmlns="urn:ietf:params:xml:ns:xmpp-sasl"><not-authorized /></failure>
  8. SEND: </stream:stream>
  9. RECV: </stream:stream>

Thanks for help and sorry for my bad english..
This post was edited on 2013-09-25, 09:55 by Alex.
Avatar
Alex #2
Member since Feb 2003 · 4322 posts · Location: Germany
Group memberships: Administrators, Members
Show profile · Link to this post
you username, password or domain is wrong. Or you set it wrong in your code.

Alex
Avatar
Frayx #3
Member since Feb 2013 · 3 posts
Group memberships: Members
Show profile · Link to this post
I'm using the example "MiniClient" and i'm sure of all the data are correct...
Avatar
Alex #4
Member since Feb 2003 · 4322 posts · Location: Germany
Group memberships: Administrators, Members
Show profile · Link to this post
If it would be correct the server would not return an auth error. If you search this forums you can find this failure again and again. And in all cases the code, server setup or entered data was wrong.
Avatar
Frayx #5
Member since Feb 2013 · 3 posts
Group memberships: Members
Show profile · Link to this post
Thanks, i'll try to reset default server settings
Close Smaller – Larger + Reply to this post:
Verification code: VeriCode Please enter the word from the image into the text field below. (Type the letters only, lower case is okay.)
Smileys: :-) ;-) :-D :-p :blush: :cool: :rolleyes: :huh: :-/ <_< :-( :'( :#: :scared: 8-( :nuts: :-O
Special characters:
Forum: agsXMPP RSS