Not logged in. · Lost password · Register
Forum: agsXMPP RSS
Avatar
[gja] #1
Member since Jul 2009 · 19 posts
Group memberships: Members
Show profile · Link to this post
Subject: cannot login to openfire
Hello Sir,

       Just want to know if what would be the other possible problem in this..my client machine(miniclient) and my server machine(windows server 2003) both ipv6 is not installed..but i still cannot connect to openfire..i am using fqdn "sample.myserver.com".and i want to not adding specific IP address in the host file of my client machine. because if i put and static IP in my client host file and then the server will change its IP address i will also change the IP in my client host file..which is not good..if you have over a thousand client machines..

thank you in advance.
glen
Avatar
Alex #2
Member since Feb 2003 · 4297 posts · Location: Germany
Group memberships: Administrators, Members
Show profile · Link to this post
Your DNS server setup is wrong then. When your DNS Setup is correct it will work without any host entries. Please fix your DNS server and add the correct SRV records for XMPP.

Alex
Avatar
tyronne #3
Member since Oct 2010 · 3 posts
Group memberships: Members
Show profile · Link to this post
Subject: cannot login to openfire
Hi

When I try to login to openfire server i get this error message please help me to solve this issues
the Debug code...


SEND: <stream:stream to='202.59.167.227' xmlns='jabber:client' xmlns:stream='http://etherx.jabber.org/streams' version='1.0' xml:lang='en'>
RECV: <stream:stream xmlns:stream="http://etherx.jabber.org/streams" from="trs01-co.danareksaonline.com" version="1.0" xml:lang="en" id="48c49655" >
RECV: <stream:features xmlns:stream="http://etherx.jabber.org/streams"><starttls xmlns="urn:ietf:params:xml:ns:xmpp-tls" /><mechanisms xmlns="urn:ietf:params:xml:ns:xmpp-sasl"><mechanism>DIGEST-MD5</mechanism><mechanism>PLAIN</mechanism><mechanism>ANONYMOUS</mechanism><mechanism>CRAM-MD5</mechanism></mechanisms><compression xmlns="http://jabber.org/features/compress"><method>zlib</method></compression><auth xmlns="http://jabber.org/features/iq-auth" /><register xmlns="http://jabber.org/features/iq-register" /></stream:features>
SEND: <auth xmlns="urn:ietf:params:xml:ns:xmpp-sasl" mechanism="PLAIN">XXXXX</auth>
RECV: <success xmlns="urn:ietf:params:xml:ns:xmpp-sasl" />
SEND: <stream:stream to='202.59.167.227' xmlns='jabber:client' xmlns:stream='http://etherx.jabber.org/streams' version='1.0' xml:lang='en'>
RECV: <stream:stream xmlns:stream="http://etherx.jabber.org/streams" from="trs01-co.danareksaonline.com" version="1.0" xml:lang="en" id="48c49655" >
RECV: <stream:features xmlns:stream="http://etherx.jabber.org/streams"><compression xmlns="http://jabber.org/features/compress"><method>zlib</method></compression><bind xmlns="urn:ietf:params:xml:ns:xmpp-bind" /><session xmlns="urn:ietf:params:xml:ns:xmpp-session" /></stream:features>
SEND: <iq id="agsXMPP_1" type="set" to="202.59.167.227"><bind xmlns="urn:ietf:params:xml:ns:xmpp-bind"><resource>abc</resource></bind></iq>
RECV: <iq xmlns="jabber:client" from="202.59.167.227" to="trs01-co.danareksaonline.com/48c49655" type="error" id="agsXMPP_1"><bind xmlns="urn:ietf:params:xml:ns:xmpp-bind"><resource>abc</resource></bind><error code="400" type="modify"><bad-request xmlns="urn:ietf:params:xml:ns:xmpp-stanzas" /></error></iq>
This post was edited on 2010-10-21, 08:58 by Alex.
Edit reason: garbled the password in the log
Avatar
Alex #4
Member since Feb 2003 · 4297 posts · Location: Germany
Group memberships: Administrators, Members
Show profile · Link to this post
your XMPP domain is trs01-co.danareksaonline.com, but you are using the IP 202.59.167.227.
Avatar
tyronne #5
Member since Oct 2010 · 3 posts
Group memberships: Members
Show profile · Link to this post
Hi Sir
Thanks for the reply but when i use "trs01-co.danareksaonline.com" it says "No such host is known"
but for the same username and password the Spark chat client works when the server is given as "202.59.167.227" but in spark when i give                              "trs01-co.danareksaonline.com" it's not working .
This post was edited on 2010-10-21, 08:25 by tyronne.
Avatar
Alex #6
Member since Feb 2003 · 4297 posts · Location: Germany
Group memberships: Administrators, Members
Show profile · Link to this post
When you don't have the correct SRV records in the DNS which is required for XMPP you can specify the hostname manual.

  1. _connection.Username = "myuser";
  2. _connection.Password = "secret";
  3. _connection.Server = "trs01-co.danareksaonline.com";
  4.  
  5. _connection.AutoResolveConnectServer = false;
  6. _connection.ConnectServer = "202.59.167.227";

Alex
Avatar
tyronne #7
Member since Oct 2010 · 3 posts
Group memberships: Members
Show profile · Link to this post
Hi sir
It worked Thank you for the reply really appreciate it
Best regards
Tyronne
Close Smaller – Larger + Reply to this post:
Verification code: VeriCode Please enter the word from the image into the text field below. (Type the letters only, lower case is okay.)
Smileys: :-) ;-) :-D :-p :blush: :cool: :rolleyes: :huh: :-/ <_< :-( :'( :#: :scared: 8-( :nuts: :-O
Special characters:
Forum: agsXMPP RSS